Knowledgebase: Apple Aperture
What version of Aperture do I need to run Light, Ozone or Power Stroke?
Posted by Marco Paolini on 18 April 2008 08:52 AM

Light, Ozone and Power Stroke require Aperture 2.1 and above.
(1089 vote(s))
Helpful
Not helpful